When Setting Up Ruby on Ubuntu [Fixing Zlib (LoadError)]

Just in the process of repaving a new desktop Ubuntu image. Installed rvm and got the following error when trying to update the gems package:

bash
1
2
$ sudo gem update --system 
... in `require': no such file to load -- zlib (LoadError)

Simple fix:

bash
1
sudo apt-get install zlib1g zlib1g-dev

After that it’s smooth sailing.

Develop With Passion®

Comments